$re = '@(?<![\w-])(?:MyNAS-2|MyNAS|Operation succeeded\.|Operation succeeded)(?![\w-])@is';
$str = '(Job: NAS-Inkrementell) Operation succeeded Operation succeeded. MyNAS-2 reports duty.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);