import re
regex = re.compile(r"(?<![\w-])(?:MyNAS-2|MyNAS|Operation succeeded\.|Operation succeeded)(?![\w-])", flags=re.IGNORECASE | re.DOTALL)
test_str = "(Job: NAS-Inkrementell) Operation succeeded Operation succeeded. MyNAS-2 reports duty."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")