re = /(?<![\w-])(?:MyNAS-2|MyNAS|Operation succeeded\.|Operation succeeded)(?![\w-])/i
str = '(Job: NAS-Inkrementell) Operation succeeded Operation succeeded. MyNAS-2 reports duty.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end