import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\w-])(?:MyNAS-2|MyNAS|Operation succeeded\\.|Operation succeeded)(?![\\w-])";
final String string = "(Job: NAS-Inkrementell) Operation succeeded Operation succeeded. MyNAS-2 reports duty.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}