const regex = new RegExp('(?<![\\w-])(?:MyNAS-2|MyNAS|Operation succeeded\\.|Operation succeeded)(?![\\w-])', 'isg')
const str = `(Job: NAS-Inkrementell) Operation succeeded Operation succeeded. MyNAS-2 reports duty.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}