#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1?\(\d{3}\)[-. ]?(\d{3})$"
Local $sString = "1(123)123" & @CRLF & _
"(123)123" & @CRLF & _
"1(123) 123" & @CRLF & _
"2(123) 123" & @CRLF & _
"1(123)%123" & @CRLF & _
"1(123)12" & @CRLF & _
"1(12)123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")