import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1?\\(\\d{3}\\)[-. ]?(\\d{3})$";
final String string = "1(123)123\n"
+ "(123)123\n"
+ "1(123) 123\n"
+ "2(123) 123\n"
+ "1(123)%123\n"
+ "1(123)12\n"
+ "1(12)123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}