re = /^1?\(\d{3}\)[-. ]?(\d{3})$/m
str = '1(123)123
(123)123
1(123) 123
2(123) 123
1(123)%123
1(123)12
1(12)123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end