package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1?\(\d{3}\)[-. ]?(\d{3})$`)
var str = `1(123)123
(123)123
1(123) 123
2(123) 123
1(123)%123
1(123)12
1(12)123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}