$re = '/^1?\(\d{3}\)[-. ]?(\d{3})$/m';
$str = '1(123)123
(123)123
1(123) 123
2(123) 123
1(123)%123
1(123)12
1(12)123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);