# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=0x)(\w+)/\U$1/gm;t' <<< "uint32_t per = 0x400e10b4u;"