re = /(?<=0x)(\w+)/m
str = 'uint32_t per = 0x400e10b4u;'
subst = '\\U$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result