const regex = /(?<=0x)(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=0x)(\\w+)', 'gm')
const str = `uint32_t per = 0x400e10b4u;`;
const subst = `\U$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);