import Foundation
let pattern = #"(?<=0x)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"uint32_t per = 0x400e10b4u;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)