use strict;
my $str = 'uint32_t per = 0x400e10b4u;';
my $regex = qr/(?<=0x)(\w+)/mp;
my $subst = '\\U$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";