$re = '/(?<=0x)(\w+)/m';
$str = 'uint32_t per = 0x400e10b4u;';
$subst = "\U$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;