using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^IF[ ]*EXISTS[ ]*[(]SELECT[ ]*1[ ]*FROM[ ]*sysobjects[ ]*o,[ ]*sysusers[ ]*u[ ]*WHERE[ ]*TYPE[ ]*=[ ]*'P'[ ]*and[ ]*o[.]name[ ]*=[ ]*\'\w*\'[ ]*AND[ ]*o[.]uid[ ]*=[ ]*u[.]uid[ ]*and[ ]*u[.]name[ ]*=[ ]*\'\w*\'[)][\s]*[ ]*DROP[ ]*PROCEDURE[ ]*\S*[ ]*\s*[ ]*GO";
string input = @"IF EXISTS(SELECT 1 FROM sysobjects o, sysusers u WHERE TYPE = 'P' and o.name = 'DI_GetFidelityRetirementEnterprise' and o.uid = u.uid and u.name = 'Escher')
DROP PROCEDURE [Escher].DI_GetFidelityRetirementEnterprise
GO";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}