import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^IF[ ]*EXISTS[ ]*[(]SELECT[ ]*1[ ]*FROM[ ]*sysobjects[ ]*o,[ ]*sysusers[ ]*u[ ]*WHERE[ ]*TYPE[ ]*=[ ]*'P'[ ]*and[ ]*o[.]name[ ]*=[ ]*\\'\\w*\\'[ ]*AND[ ]*o[.]uid[ ]*=[ ]*u[.]uid[ ]*and[ ]*u[.]name[ ]*=[ ]*\\'\\w*\\'[)][\\s]*[ ]*DROP[ ]*PROCEDURE[ ]*\\S*[ ]*\\s*[ ]*GO";
final String string = "IF EXISTS(SELECT 1 FROM sysobjects o, sysusers u WHERE TYPE = 'P' and o.name = 'DI_GetFidelityRetirementEnterprise' and o.uid = u.uid and u.name = 'Escher')\n"
+ " DROP PROCEDURE [Escher].DI_GetFidelityRetirementEnterprise\n"
+ "GO";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}