package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^IF[ ]*EXISTS[ ]*[(]SELECT[ ]*1[ ]*FROM[ ]*sysobjects[ ]*o,[ ]*sysusers[ ]*u[ ]*WHERE[ ]*TYPE[ ]*=[ ]*'P'[ ]*and[ ]*o[.]name[ ]*=[ ]*\'\w*\'[ ]*AND[ ]*o[.]uid[ ]*=[ ]*u[.]uid[ ]*and[ ]*u[.]name[ ]*=[ ]*\'\w*\'[)][\s]*[ ]*DROP[ ]*PROCEDURE[ ]*\S*[ ]*\s*[ ]*GO`)
var str = `IF EXISTS(SELECT 1 FROM sysobjects o, sysusers u WHERE TYPE = 'P' and o.name = 'DI_GetFidelityRetirementEnterprise' and o.uid = u.uid and u.name = 'Escher')
DROP PROCEDURE [Escher].DI_GetFidelityRetirementEnterprise
GO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}