const regex = /^IF[ ]*EXISTS[ ]*[(]SELECT[ ]*1[ ]*FROM[ ]*sysobjects[ ]*o,[ ]*sysusers[ ]*u[ ]*WHERE[ ]*TYPE[ ]*=[ ]*'P'[ ]*and[ ]*o[.]name[ ]*=[ ]*\'\w*\'[ ]*AND[ ]*o[.]uid[ ]*=[ ]*u[.]uid[ ]*and[ ]*u[.]name[ ]*=[ ]*\'\w*\'[)][\s]*[ ]*DROP[ ]*PROCEDURE[ ]*\S*[ ]*\s*[ ]*GO/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^IF[ ]*EXISTS[ ]*[(]SELECT[ ]*1[ ]*FROM[ ]*sysobjects[ ]*o,[ ]*sysusers[ ]*u[ ]*WHERE[ ]*TYPE[ ]*=[ ]*\'P\'[ ]*and[ ]*o[.]name[ ]*=[ ]*\\\'\\w*\\\'[ ]*AND[ ]*o[.]uid[ ]*=[ ]*u[.]uid[ ]*and[ ]*u[.]name[ ]*=[ ]*\\\'\\w*\\\'[)][\\s]*[ ]*DROP[ ]*PROCEDURE[ ]*\\S*[ ]*\\s*[ ]*GO', 'gmi')
const str = `IF EXISTS(SELECT 1 FROM sysobjects o, sysusers u WHERE TYPE = 'P' and o.name = 'DI_GetFidelityRetirementEnterprise' and o.uid = u.uid and u.name = 'Escher')
DROP PROCEDURE [Escher].DI_GetFidelityRetirementEnterprise
GO`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}