# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[ \t]*([#]+[^\n]+)\n[ \t]*([^#\n]+.*?)\n/$1$2/gm;t' <<< "# abcd abcd abcd abcd
efgh efgh efgh efgh
## ijk ijk ijk ijk ijk ijk
lmn lmn lmn
# opq opq opq opq
rst rst #rest rst
"