const regex = /^[ \t]*([#]+[^\n]+)\n[ \t]*([^#\n]+.*?)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\t]*([#]+[^\\n]+)\\n[ \\t]*([^#\\n]+.*?)\\n', 'gm')
const str = `# abcd abcd abcd abcd
efgh efgh efgh efgh
## ijk ijk ijk ijk ijk ijk
lmn lmn lmn
# opq opq opq opq
rst rst #rest rst
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);