re = /^[ \t]*([#]+[^\n]+)\n[ \t]*([^#\n]+.*?)\n/m
str = '# abcd abcd abcd abcd
efgh efgh efgh efgh
## ijk ijk ijk ijk ijk ijk
lmn lmn lmn
# opq opq opq opq
rst rst #rest rst
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result