import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*([#]+[^\\n]+)\\n[ \\t]*([^#\\n]+.*?)\\n";
final String string = "# abcd abcd abcd abcd \n"
+ "efgh efgh efgh efgh \n\n"
+ " ## ijk ijk ijk ijk ijk ijk \n"
+ "lmn lmn lmn \n\n"
+ " # opq opq opq opq \n"
+ "rst rst #rest rst \n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}