using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \t]*([#]+[^\n]+)\n[ \t]*([^#\n]+.*?)\n";
string substitution = @"$1$2";
string input = @"# abcd abcd abcd abcd
efgh efgh efgh efgh
## ijk ijk ijk ijk ijk ijk
lmn lmn lmn
# opq opq opq opq
rst rst #rest rst
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}