// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ \t]*([#]+[^\n]+)\n[ \t]*([^#\n]+.*?)\n").unwrap();
let string = "# abcd abcd abcd abcd
efgh efgh efgh efgh
## ijk ijk ijk ijk ijk ijk
lmn lmn lmn
# opq opq opq opq
rst rst #rest rst
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}