#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\()?(\+62|62|0)(\d{2,3})?\)?[ .-]?\d{2,4}[ .-]?\d{2,4}[ .-]?\d{2,4}"
Local $sString = "here is my phone (0817)34567890" & @CRLF & _
"0817.3456.7890" & @CRLF & _
"0817 3456 7890" & @CRLF & _
"(+62) 81734567890" & @CRLF & _
"(+62) 817-3456-7890" & @CRLF & _
"+6281734567890" & @CRLF & _
"+62-817-3456-7890" & @CRLF & _
"+62817 3456 7890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")