using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\()?(\+62|62|0)(\d{2,3})?\)?[ .-]?\d{2,4}[ .-]?\d{2,4}[ .-]?\d{2,4}";
string input = @"here is my phone (0817)34567890
0817.3456.7890
0817 3456 7890
(+62) 81734567890
(+62) 817-3456-7890
+6281734567890
+62-817-3456-7890
+62817 3456 7890";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}