package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\()?(\+62|62|0)(\d{2,3})?\)?[ .-]?\d{2,4}[ .-]?\d{2,4}[ .-]?\d{2,4}`)
var str = `here is my phone (0817)34567890
0817.3456.7890
0817 3456 7890
(+62) 81734567890
(+62) 817-3456-7890
+6281734567890
+62-817-3456-7890
+62817 3456 7890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}