import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\()?(\\+62|62|0)(\\d{2,3})?\\)?[ .-]?\\d{2,4}[ .-]?\\d{2,4}[ .-]?\\d{2,4}";
final String string = "here is my phone (0817)34567890\n"
+ "0817.3456.7890\n"
+ "0817 3456 7890\n"
+ "(+62) 81734567890\n"
+ "(+62) 817-3456-7890\n"
+ "+6281734567890\n"
+ "+62-817-3456-7890\n"
+ "+62817 3456 7890";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}