using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?=([^\s\(]+ )*\S*\))(?!\S*\s*\()";
string substitution = @"";
string input = @"foobar baz (somesampletextinhere)blah(some sample text in here) and some more
foobar baz (some sampletextinhere) blah (some sample text in here) and some more
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}