$re = '/ (?=([^\s\(]+ )*\S*\))(?!\S*\s*\()/m';
$str = 'foobar baz (somesampletextinhere)blah(some sample text in here) and some more
foobar baz (some sampletextinhere) blah (some sample text in here) and some more
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;