re = / (?=([^\s\(]+ )*\S*\))(?!\S*\s*\()/m
str = 'foobar baz (somesampletextinhere)blah(some sample text in here) and some more
foobar baz (some sampletextinhere) blah (some sample text in here) and some more
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result