import re
regex = re.compile(r" (?=([^\s\(]+ )*\S*\))(?!\S*\s*\()", flags=re.MULTILINE)
test_str = ("foobar baz (somesampletextinhere)blah(some sample text in here) and some more\n"
"foobar baz (some sampletextinhere) blah (some sample text in here) and some more\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)