const regex = / (?=([^\s\(]+ )*\S*\))(?!\S*\s*\()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?=([^\\s\\(]+ )*\\S*\\))(?!\\S*\\s*\\()', 'gm')
const str = `foobar baz (somesampletextinhere)blah(some sample text in here) and some more
foobar baz (some sampletextinhere) blah (some sample text in here) and some more
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);