#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\+?[\d\s?]{10,15})"
Local $sString = "004219126559874" & @CRLF & _
"0908312334" & @CRLF & _
"+421908332314" & @CRLF & _
"+420987654321" & @CRLF & _
"+420 987 654 321" & @CRLF & _
"+421 223 987 828" & @CRLF & _
"0913987654"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")