using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\+?[\d\s?]{10,15})";
string input = @"004219126559874
0908312334
+421908332314
+420987654321
+420 987 654 321
+421 223 987 828
0913987654";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}