package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\+?[\d\s?]{10,15})`)
var str = `004219126559874
0908312334
+421908332314
+420987654321
+420 987 654 321
+421 223 987 828
0913987654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}