use strict;
my $str = '004219126559874
0908312334
+421908332314
+420987654321
+420 987 654 321
+421 223 987 828
0913987654';
my $regex = qr/(^\+?[\d\s?]{10,15})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}