// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\+?[\d\s?]{10,15})").unwrap();
let string = "004219126559874
0908312334
+421908332314
+420987654321
+420 987 654 321
+421 223 987 828
0913987654";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}