#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.*[\/\\](?<FileNameWithoutExtension>.*)\.(.*)$"
Local $sString = "\.\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")