re = /^.*[\/\\](?<FileNameWithoutExtension>.*)\.(.*)$/
str = '\\.\\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip'
# Print the match result
str.match(re) do |match|
puts match.to_s
end