import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*[\\/\\\\](?<FileNameWithoutExtension>.*)\\.(.*)$";
final String string = "\\.\\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}