$re = '/^.*[\/\\\\](?<FileNameWithoutExtension>.*)\.(.*)$/';
$str = '\\.\\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);