import Foundation
let pattern = #"^.*[\/\\](?<FileNameWithoutExtension>.*)\.(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"\.\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}