#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^x\/\(x\+\d+\)\s*=\s*\(\d+x\)\/\d+$"
Local $sString = "x/(x+70) = (4x)/2" & @CRLF & _
"" & @CRLF & _
"x/(x+7)=(4x)/2" & @CRLF & _
"" & @CRLF & _
"x/(x+7) " & @CRLF & _
"= " & @CRLF & _
"(4x)/2" & @CRLF & _
"" & @CRLF & _
"x/(x+7)=(4x)/28"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")