const regex = new RegExp('^x\\/\\(x\\+\\d+\\)\\s*=\\s*\\(\\d+x\\)\\/\\d+$', 'gm')
const str = `x/(x+70) = (4x)/2
x/(x+7)=(4x)/2
x/(x+7)
=
(4x)/2
x/(x+7)=(4x)/28`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}