re = /^x\/\(x\+\d+\)\s*=\s*\(\d+x\)\/\d+$/m
str = 'x/(x+70) = (4x)/2
x/(x+7)=(4x)/2
x/(x+7)
=
(4x)/2
x/(x+7)=(4x)/28'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end