using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^x\/\(x\+\d+\)\s*=\s*\(\d+x\)\/\d+$";
string input = @"x/(x+70) = (4x)/2
x/(x+7)=(4x)/2
x/(x+7)
=
(4x)/2
x/(x+7)=(4x)/28";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}