package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^x\/\(x\+\d+\)\s*=\s*\(\d+x\)\/\d+$`)
var str = `x/(x+70) = (4x)/2
x/(x+7)=(4x)/2
x/(x+7)
=
(4x)/2
x/(x+7)=(4x)/28`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}